CVE-2016-1000110

Priority
Description
use of HTTP_PROXY flag supplied by attacker in CGI scripts
Notes
 sbeattie> may also need patches from https://bugs.python.org/issue26804
Package
Upstream:released (2.7.12-2)
Ubuntu 12.04 ESM (Precise Pangolin):released (2.7.3-0ubuntu3.9)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.7.6-8ubuntu0.3)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.7.12-1ubuntu0~16.04.1)
Patches:
Upstream:https://hg.python.org/cpython/rev/ba915d561667/
Upstream:https://hg.python.org/cpython/rev/c502deb19cb0
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [3.2.3-0ubuntu3.8])
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:pending (3.4.6rc1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (3.4.3-1ubuntu1~14.04.5)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
Upstream:https://hg.python.org/cpython/rev/3c19023c9fec
Package
Upstream:released (3.5.2-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):released (3.5.2-2ubuntu0~16.04.1)
Patches:
Upstream:https://hg.python.org/cpython/rev/95b09ccc8a3e
Upstream:https://hg.python.org/cpython/rev/49b975122022
More Information

Updated: 2018-10-31 21:22:12 UTC (commit cfa7cf69d76449ccff972ac22f40976a08d908c2)