CVE-2016-1000108

Priority
Description
yaws before 2.0.4 does not attempt to address RFC 3875 section 4.1.18
namespace conflicts and therefore does not protect CGI applications from
the presence of untrusted client data in the HTTP_PROXY environment
variable, which might allow remote attackers to redirect a CGI
application's outbound HTTP traffic to an arbitrary proxy server via a
crafted Proxy header in an HTTP request, aka an "httpoxy" issue.
Notes
Package
Source: yaws (LP Ubuntu Debian)
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.0.3-2)
Ubuntu 19.10 (Eoan Ermine):not-affected (2.0.3-2)
Ubuntu 20.04 (Focal Fossa):not-affected (2.0.3-2)
More Information

Updated: 2020-04-24 03:20:02 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)