CVE-2016-0799

Priority
Description
The fmtstr function in crypto/bio/b_print.c in OpenSSL 1.0.1 before 1.0.1s
and 1.0.2 before 1.0.2g improperly calculates string lengths, which allows
remote attackers to cause a denial of service (overflow and out-of-bounds
read) or possibly have unspecified other impact via a long string, as
demonstrated by a large amount of ASN.1 data, a different vulnerability
than CVE-2016-2842.
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (1.0.1-4ubuntu5.35)
Ubuntu 14.04 LTS (Trusty Tahr):released (1.0.1f-1ubuntu2.18)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.0.2g-1ubuntu2)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.0.2g-1ubuntu2)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1.0.2g-1ubuntu2)
Ubuntu 19.04 (Disco Dingo):released (1.0.2g-1ubuntu2)
Patches:
Upstream:https://git.openssl.org/?p=openssl.git;a=commit;h=a801bf263849a2ef773e5bc0c86438cbba720835 (1.0.1)
Upstream:https://git.openssl.org/?p=openssl.git;a=commit;h=578b956fe741bf8e84055547b1e83c28dd902c73 (1.0.2)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-01-14 21:18:16 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)