CVE-2016-0724

Priority
Description
The (1) core_enrol_get_course_enrolment_methods and (2)
enrol_self_get_instance_info web services in Moodle through 2.6.11, 2.7.x
before 2.7.12, 2.8.x before 2.8.10, 2.9.x before 2.9.4, and 3.0.x before
3.0.2 do not consider the moodle/course:viewhiddencourses capability, which
allows remote authenticated users to obtain sensitive information via a
web-service request.
Package
Upstream:released (2.7.12+dfsg-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.7.12+dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.7.12+dfsg-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.7.12+dfsg-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.7.12+dfsg-1)
Patches:
Upstream:http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-52072
More Information

Updated: 2019-01-14 21:18:13 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)