CVE-2015-9274

Priority
Description
HarfBuzz before 1.0.4 allows remote attackers to cause a denial of service
(invalid read of two bytes and application crash) because of GPOS and GSUB
table mishandling, related to hb-ot-layout-gpos-table.hh,
hb-ot-layout-gsub-table.hh, and hb-ot-layout-gsubgpos-private.hh.
Package
Upstream:released (1.2.6-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.7.2-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Ubuntu 19.10 (Eoan):not-affected
Patches:
Upstream:https://github.com/harfbuzz/harfbuzz/commit/c917965b9e6fe2b21ed6c51559673288fa3af4b7
More Information

Updated: 2019-04-26 14:15:49 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)