CVE-2015-9251

Priority
Description
jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks
when a cross-domain Ajax request is performed without the dataType option,
causing text/javascript responses to be executed.
Notes
 mdeslaur> fix is intrusive and backwards-incompatible, see bug 3011
Package
Upstream:released (3.1.1-1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Patches:
Upstream:https://github.com/jquery/jquery/commit/f60729f3903d17917dc351f3ac87794de379b0cc
More Information

Updated: 2019-01-14 21:18:02 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)