CVE-2015-8875 (retired)

Priority
Description
Multiple integer overflows in the (1) pixops_composite_nearest, (2)
pixops_composite_color_nearest, and (3) pixops_process functions in
pixops/pixops.c in gdk-pixbuf before 2.33.1 allow remote attackers to cause
a denial of service (application crash) or possibly execute arbitrary code
via a crafted image, which triggers a heap-based buffer overflow.
Notes
 sbeattie> in their wheezy update, debian identified this fix as
  CVE-2015-7674-part2.patch (in 2.26.1-1+deb7u4).
Package
Upstream:released (2.32.2, 2.34.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [2.26.1-1ubuntu1.5])
Ubuntu 14.04 LTS (Trusty Tahr):released (2.30.7-0ubuntu1.6)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.32.2-1ubuntu1)
Patches:
Upstream:https://git.gnome.org/browse/gdk-pixbuf/commit/?id=dbfe8f70471864818bf458a39c8a99640895bd22
More Information

Updated: 2019-03-26 12:17:49 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)