CVE-2015-8857

Priority
Description
The uglify-js package before 2.4.24 for Node.js does not properly account
for non-boolean values when rewriting boolean expressions, which might
allow attackers to bypass security mechanisms or possibly have unspecified
other impact by leveraging improperly rewritten Javascript.
Notes
Package
Upstream:released (2.4.24)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.8.29-3)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (2.8.29-3)
Ubuntu 20.10 (Groovy Gorilla):not-affected (2.8.29-3)
Patches:
Upstream:https://github.com/mishoo/UglifyJS2/commit/905b6011784ca60d41919ac1a499962b7c1d4b02
More Information

Updated: 2020-07-28 18:31:40 UTC (commit 7b6828437fde0509248708fcdb5b0f7587b85bd1)