CVE-2015-8851 (retired)

Priority
Description
node-uuid prior to 1.4.4 contained a bug that caused it to consistently
fall back to using Math.random instead of a more cryptographically sound
source of entropy, the native crypto module.
Notes
msalvatoreIntroduced in commit 319dc6e2e75f8ff57e9e708e2187bdabba6ca86a
Package
Upstream:released (1.4.4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.4.7-5)
Patches:
Upstream:https://github.com/broofa/node-uuid/commit/672f3834ed02c798aa021c618d0a5666c8da000d
More Information

Updated: 2019-10-09 07:54:30 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)