CVE-2015-8393

Priority
Description
pcregrep in PCRE before 8.38 mishandles the -q option for binary files,
which might allow remote attackers to obtain sensitive information via a
crafted file, as demonstrated by a CGI script that sends stdout data to a
client.
Notes
tyhicksIssue affects PCRE3 only
mdeslaur0001-Make-pcregrep-q-override-l-and-c-for-compatibility-w.patch
in jessie
Package
Source: pcre2 (LP Ubuntu Debian)
Upstream:not-affected
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Package
Source: pcre3 (LP Ubuntu Debian)
Upstream:released (8.38)
Ubuntu 12.04 ESM (Precise Pangolin):released (8.12-4ubuntu0.2)
Ubuntu 14.04 ESM (Trusty Tahr):released (1:8.31-2ubuntu2.2)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2:8.38-3)
Patches:
Upstream:http://vcs.pcre.org/pcre?view=revision&revision=1586
More Information

Updated: 2020-09-10 04:56:23 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)