CVE-2015-8239

Priority
Description
The SHA-2 digest support in the sudoers plugin in sudo after 1.8.7 allows
local users with write permissions to parts of the called command to
replace them before it is executed.
Notes
 sbeattie> command digests are available only in 1.8.7 and higher
Package
Source: sudo (LP Ubuntu Debian)
Upstream:released (1.8.16)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code does not exist)
Trusty/esm:needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.8.16-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.8.16-0ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.8.16-0ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (1.8.16-0ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (1.8.16-0ubuntu1)
Patches:
Upstream:https://www.sudo.ws/repos/sudo/rev/397722cdd7ec
More Information

Updated: 2019-04-26 14:15:39 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)