CVE-2015-7975

Priority
Description
The nextvar function in NTP before 4.2.8p6 and 4.3.x before 4.3.90 does not
properly validate the length of its input, which allows an attacker to
cause a denial of service (application crash).
Notes
mdeslaurintroduced in 4.2.8 by
https://github.com/ntp-project/ntp/commit/be565bf3c6a5badd4a6ce2f336476d1e1dd98915
Package
Source: ntp (LP Ubuntu Debian)
Upstream:released (4.2.8p6)
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (1:4.2.6.p5+dfsg-3ubuntu2.14.04.8)
Ubuntu 16.06 ESM (Xenial Xerus):released (1:4.2.8p4+dfsg-3ubuntu5.3)
Patches:
Upstream:https://github.com/ntp-project/ntp/commit/12f1323d18c8d74eb14fb5ac5574183d779794c5
More Information

Updated: 2021-06-05 04:36:55 UTC (commit 9f1442d151c4b1764735c64061fe3a60c369dce8)