CVE-2015-7940 (retired)

Priority
Description
The Bouncy Castle Java library before 1.51 does not validate a point is
withing the elliptic curve, which makes it easier for remote attackers to
obtain private keys via a series of crafted elliptic curve Diffie Hellman
(ECDH) key exchanges, aka an "invalid curve attack."
Notes
 mdeslaur> no reverse depends in main
Package
Upstream:released (1.51-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):released (1.49+dfsg-2ubuntu0.1)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.51-4ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.59-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.60-1)
Patches:
Upstream:https://github.com/bcgit/bc-java/commit/5cb2f0578e6ec8f0d67e59d05d8c4704d8e05f83
Upstream:https://github.com/bcgit/bc-java/commit/e25e94a046a6934819133886439984e2fecb2b04
More Information

Updated: 2019-03-26 12:17:06 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)