CVE-2015-7555

Priority
Description
Heap-based buffer overflow in giffix.c in giffix in giflib 5.1.1 allows
attackers to cause a denial of service (program crash) via crafted image
and logical screen width fields in a GIF file.
Notes
 msalvatore> patch released in 4.1.6-11+deb8u1
Package
Upstream:released (4.1.6-11+deb8u1, 5.1.2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (5.1.2-0.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (5.1.2-0.1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (5.1.2-0.1)
Ubuntu 19.04 (Disco Dingo):not-affected (5.1.2-0.1)
Patches:
Upstream:http://sourceforge.net/p/giflib/code/ci/179510be300bf11115e37528d79619b53c884a63
More Information

Updated: 2019-01-14 21:17:40 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)