CVE-2015-6938

Priority
Description
Cross-site scripting (XSS) vulnerability in the file browser in
notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter
Notebook 4.0.x before 4.0.5 allows remote attackers to inject arbitrary web
script or HTML via a folder name. NOTE: this was originally reported as a
cross-site request forgery (CSRF) vulnerability, but this may be
inaccurate.
Notes
tyhicks"Affected versions: 0.12 <= version <= 4.0"
Package
Upstream:released (2.4.1-1, 5.1.0-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.4.1-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (5.5.0-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (5.5.0-1)
Ubuntu 20.04 (Focal Fossa):not-affected (5.5.0-1)
More Information

Updated: 2020-04-24 03:19:10 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)