CVE-2015-6822

Priority
Description
The destroy_buffers function in libavcodec/sanm.c in FFmpeg before 2.7.2
does not properly maintain height and width values in the video context,
which allows remote attackers to cause a denial of service (segmentation
violation and application crash) or possibly have unspecified other impact
via crafted LucasArts Smush video data.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (7:2.8.3-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (7:2.8.3-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (7:2.8.3-1)
Patches:
Upstream:http://git.videolan.org/?p=ffmpeg.git;a=commit;h=39bbdebb1ed8eb9c9b0cd6db85afde6ba89d86e4
Package
Source: libav (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected [code not present])
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
More Information

Updated: 2019-03-19 12:22:55 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)