CVE-2015-6821

Priority
Description
The ff_mpv_common_init function in libavcodec/mpegvideo.c in FFmpeg before
2.7.2 does not properly maintain the encoding context, which allows remote
attackers to cause a denial of service (invalid pointer access) or possibly
have unspecified other impact via crafted MPEG data.
Notes
mdeslauras of 2016-03-11, no equivalent fix in libav
code is different in precise, probably ok
ebarrettoas of 2018-09-27, no equivalent fix in libav
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (7:2.8.3-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (7:2.8.3-1)
Patches:
Upstream:http://git.videolan.org/?p=ffmpeg.git;a=commit;h=b160fc290cf49b516c5b6ee0730fd9da7fc623b1
Package
Source: libav (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected [4:0.8.17-0ubuntu0.12.04.1])
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was ignored)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
More Information

Updated: 2020-09-10 04:51:10 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)