CVE-2015-6031

Priority
Description
Buffer overflow in the IGDstartelt function in igd_desc_parse.c in the
MiniUPnP client (aka MiniUPnPc) before 1.9.20150917 allows remote UPNP
servers to cause a denial of service (application crash) and possibly
execute arbitrary code via an "oversized" XML element name.
Assigned-to
sbeattie
Notes
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [1.6-3ubuntu2.14.04.2])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.9.20140610-2ubuntu2)
Patches:
Upstream:https://github.com/miniupnp/miniupnp/commit/79cca974a4c2ab1199786732a67ff6d898051b78
More Information

Updated: 2020-09-10 04:49:23 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)