CVE-2015-5316

Priority
Description
The eap_pwd_perform_confirm_exchange function in eap_peer/eap_pwd.c in
wpa_supplicant 2.x before 2.6, when EAP-pwd is enabled in a network
configuration profile, allows remote attackers to cause a denial of service
(NULL pointer dereference and daemon crash) via an EAP-pwd Confirm message
followed by the Identity exchange.
Assigned-to
mdeslaur
Notes
mdeslaurlooks like it was introduced by
1f1fe195cd8907badca6d4ee17e5fa638b6f83db, so only wily+
Package
Source: wpa (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (code not vulnerable)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.4-0ubuntu5)
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
More Information

Updated: 2019-12-05 18:42:22 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)