CVE-2015-5314

Priority
Description
The eap_pwd_process function in eap_server/eap_server_pwd.c in hostapd 2.x
before 2.6 does not validate that the reassembly buffer is large enough for
the final fragment when used with (1) an internal EAP server or (2) a
RADIUS server and EAP-pwd is enabled in a runtime configuration, which
allows remote attackers to cause a denial of service (process termination)
via a large final fragment in an EAP-pwd message.
Assigned-to
mdeslaur
Notes
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Source: wpa (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):released (2.1-0ubuntu1.4)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.4-0ubuntu5)
More Information

Updated: 2019-12-05 18:42:22 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)