CVE-2015-5191

Priority
Description
VMware Tools prior to 10.0.9 contains multiple file system races in
libDeployPkg, related to the use of hard-coded paths under /tmp. Successful
exploitation of this issue may result in a local privilege escalation.
CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
Notes
mdeslaurprobably DoS only with symlink restrictions
Package
Upstream:released (2:10.1.5-5055683-5)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2:10.1.5-5055683-5ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (2:10.1.5-5055683-5ubuntu1)
Ubuntu 19.10 (Eoan Ermine):not-affected (2:10.1.5-5055683-5ubuntu1)
Ubuntu 20.04 (Focal Fossa):not-affected (2:10.1.5-5055683-5ubuntu1)
Patches:
Upstream:https://github.com/vmware/open-vm-tools/commit/c1304ce8bfd9c0c33999e496bf7049d5c3d45821 (9)
Upstream:https://github.com/vmware/open-vm-tools/commit/b3068b04880eda4ca3e13f2d34fb8ce336ad1a4f (10.0)
Upstream:https://github.com/vmware/open-vm-tools/commit/22e58289f71232310d30cf162b83b5151a937bac (10.1)
This vulnerability is mitigated in part by the use of symlink restrictions in Ubuntu. For more details see https://wiki.ubuntu.com/Security/Features#symlink
More Information

Updated: 2019-12-05 19:25:21 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)