CVE-2015-5073 (retired)

Priority
Description
Heap-based buffer overflow in the find_fixedlength function in
pcre_compile.c in PCRE before 8.38 allows remote attackers to cause a
denial of service (crash) or obtain sensitive information from heap memory
and possibly bypass the ASLR protection mechanism via a crafted regular
expression with an excess closing parenthesis.
Notes
 mdeslaur> in wily, this was already fixed by the fix_find_fixedlength
 mdeslaur> patch, but the testcases weren't included
 mdeslaur>
 mdeslaur> was supposed to be fixed in wily (2:8.35-7ubuntu2) but got
 mdeslaur> reverted in (2:8.35-7ubuntu5) by mistake
 mdeslaur>
 mdeslaur> CVE-2015-2325_CVE-2015-2326_CVE-2015-3210_CVE-2015-5073.patch
 mdeslaur> in jessie
Assigned-to
mdeslaur
Package
Source: pcre3 (LP Ubuntu Debian)
Upstream:released (2:8.35-7)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:8.31-2ubuntu2.1)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2:8.38-3)
Patches:
Upstream:http://vcs.pcre.org/pcre?view=revision&revision=1571
More Information

Updated: 2019-03-26 12:15:52 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)