CVE-2015-4707

Priority
Description
Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows
remote attackers to inject arbitrary web script or HTML via vectors
involving JSON error messages and the /api/notebooks path.
Notes
 tyhicks> It isn't clear if iPython versions less than 2.0 are affected
 debian> Problematic code introduced in rel-2.0.0
Package
Upstream:released (2.4.1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.4.1-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.4.1-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.4.1-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.4.1-1)
More Information

Updated: 2019-01-14 21:17:14 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)