CVE-2015-4142 (retired)

Priority
Description
Integer underflow in the WMM Action frame parser in hostapd 0.5.5 through
2.4 and wpa_supplicant 0.7.0 through 2.4, when used for AP mode MLME/SME
functionality, allows remote attackers to cause a denial of service (crash)
via a crafted frame, which triggers an out-of-bounds read.
Assigned-to
mdeslaur
Package
Upstream:pending (2.5)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
Other:http://w1.fi/security/2015-3/0001-AP-WMM-Fix-integer-underflow-in-WMM-Action-frame-par.patch
Package
Source: wpa (LP Ubuntu Debian)
Upstream:pending (2.5)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (2.1-0ubuntu1.3)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.1-0ubuntu8)
Patches:
Other:http://w1.fi/security/2015-3/0001-AP-WMM-Fix-integer-underflow-in-WMM-Action-frame-par.patch
Package
Upstream:pending (2.5)
Ubuntu 12.04 ESM (Precise Pangolin):released (0.7.3-6ubuntu2.4)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
Other:http://w1.fi/security/2015-3/0001-AP-WMM-Fix-integer-underflow-in-WMM-Action-frame-par.patch
More Information

Updated: 2019-03-26 12:15:31 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)