CVE-2015-4116

Priority
Description
Use-after-free vulnerability in the spl_ptr_heap_insert function in
ext/spl/spl_heap.c in PHP before 5.5.27 and 5.6.x before 5.6.11 allows
remote attackers to execute arbitrary code by triggering a failed
SplMinHeap::compare operation.
Notes
sbeattierequires malformed php code, which is not usually part of a
threat model (accepting and executing random php statements)
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.6.11+dfsg-1)
Ubuntu 14.04 ESM (Trusty Tahr):released (5.5.9+dfsg-1ubuntu4.19)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=1cbd25ca15383394ffa9ee8601c5de4c0f2f90e1
More Information

Updated: 2020-03-18 22:38:58 UTC (commit 2ea7df7bd1e69e1e489978d2724a936eb3faa1b8)