CVE-2015-3395 (retired)

Priority
Description
The msrle_decode_pal4 function in msrledec.c in Libav before 10.7 and 11.x
before 11.4 and FFmpeg before 2.0.7, 2.2.x before 2.2.15, 2.4.x before
2.4.8, 2.5.x before 2.5.6, and 2.6.x before 2.6.2 allows remote attackers
to have unspecified impact via a crafted image, related to a pixel pointer,
which triggers an out-of-bounds array access.
Package
Upstream:released
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored)
Trusty/esm:DNE (trusty was released [47.0.2526.73-0ubuntu0.14.04.1.1106])
Ubuntu 16.04 LTS (Xenial Xerus):released (47.0.2526.73-0ubuntu1.1218)
Ubuntu 18.04 LTS (Bionic Beaver):released (47.0.2526.73-0ubuntu1.1218)
Ubuntu 18.10 (Cosmic Cuttlefish):released (47.0.2526.73-0ubuntu1.1218)
Ubuntu 19.04 (Disco Dingo):released (47.0.2526.73-0ubuntu1.1218)
Ubuntu 19.10 (Eoan):released (47.0.2526.73-0ubuntu1.1218)
Package
Upstream:released (2.5.6,2.6.2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (7:2.8.3-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (7:2.8.3-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (7:2.8.3-1)
Ubuntu 19.04 (Disco Dingo):not-affected (7:2.8.3-1)
Ubuntu 19.10 (Eoan):not-affected (7:2.8.3-1)
Patches:
Upstream:https://github.com/FFmpeg/FFmpeg/commit/dfce316c12d867400fb132ff5094163e3d2634a3
Upstream:https://github.com/FFmpeg/FFmpeg/commit/f7e1367f58263593e6cee3c282f7277d7ee9d553
Package
Source: libav (LP Ubuntu Debian)
Upstream:released (11.4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [4:0.8.17-0ubuntu0.12.04.2])
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Patches:
Upstream:https://git.libav.org/?p=libav.git;a=commit;h=5ecabd3c54b7c802522dc338838c9a4c2dc42948
Package
Upstream:not-affected (1.19.4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE (trusty was not-affected [1.19.4-0ubuntu0.14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.19.4-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-04-26 14:34:31 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)