CVE-2015-3245

Priority
Description
Incomplete blacklist vulnerability in the chfn function in libuser before
0.56.13-8 and 0.60 before 0.60-7, as used in the userhelper program in the
usermode package, allows local users to cause a denial of service
(/etc/passwd corruption) via a newline character in the GECOS field.
Package
Upstream:released (1:0.62~dfsg-0.1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:0.62~dfsg-0.1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1:0.62~dfsg-0.1)
Ubuntu 19.04 (Disco Dingo):not-affected (1:0.62~dfsg-0.1)
Ubuntu 19.10 (Eoan):not-affected (1:0.62~dfsg-0.1)
Patches:
Upstream:https://fedorahosted.org/libuser/changeset/d73aa2a5a9ce5bdd349dff46e3e4885f2b194a95/
More Information

Updated: 2019-04-26 14:15:16 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)