CVE-2015-3239

Priority
Description
Off-by-one error in the dwarf_to_unw_regnum function in include/dwarf_i.h
in libunwind 1.1 allows local users to have unspecified impact via invalid
dwarf opcodes.
Notes
sarnoldI saw nothing in callers of this macro that would prevent
less-than-zero accesses: input params were sometimes integers, sometimes
harder to determine the type. Debian codesearch shows many duplications of
the <= mistake with dwarf_to_unw_regnum arrays in other files, not just the
one dwarf_i.h.
Package
Upstream:released (7.0.0+r1-4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (7.0.0+r1-4)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (8.1.0+r23-2)
Ubuntu 20.10 (Groovy Gorilla):not-affected (8.1.0+r23-2)
Patches:
Upstream:http://git.savannah.gnu.org/cgit/libunwind.git/commit/?id=396b6c7ab737e2bff244d640601c436a26260ca1
Package
Upstream:released (0.99-0.2+deb6u1, 1.1-4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.1-4.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.1-4.1)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (1.1-4.1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (1.1-4.1)
Patches:
Upstream:http://git.savannah.gnu.org/cgit/libunwind.git/commit/?id=396b6c7ab737e2bff244d640601c436a26260ca1
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):needed
Ubuntu 20.10 (Groovy Gorilla):needed
Patches:
Other:http://git.savannah.gnu.org/cgit/libunwind.git/commit/?id=396b6c7ab737e2bff244d640601c436a26260ca1
More Information

Updated: 2020-07-28 18:27:27 UTC (commit 7b6828437fde0509248708fcdb5b0f7587b85bd1)