CVE-2015-3210 (retired)

Priority
Description
Heap-based buffer overflow in PCRE 8.34 through 8.37 and PCRE2 10.10 allows
remote attackers to execute arbitrary code via a crafted regular
expression, as demonstrated by
/^(?P=B)((?P=B)(?J:(?P<B>c)(?P<B>a(?P=B)))>WGXCREDITS)/, a different
vulnerability than CVE-2015-8384.
Notes
 sarnold> "A number of such bugs have recently been discovered by fuzzers",
  it might be a good idea to trawl the source repo for more such fixes.
 mdeslaur> Debian claims introduced in
 mdeslaur> http://vcs.pcre.org/pcre?view=revision&revision=1361
 mdeslaur>
 mdeslaur> was supposed to be fixed in wily (2:8.35-7ubuntu2) but got
 mdeslaur> reverted in (2:8.35-7ubuntu5) by mistake
 mdeslaur>
 mdeslaur> CVE-2015-2325_CVE-2015-2326_CVE-2015-3210_CVE-2015-5073.patch
 mdeslaur> in jessie
Assigned-to
mdeslaur
Package
Source: pcre3 (LP Ubuntu Debian)
Upstream:needed
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (1:8.31-2ubuntu2)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2:8.38-3)
Patches:
Upstream:http://vcs.pcre.org/pcre?view=revision&revision=1558
More Information

Updated: 2019-03-26 12:15:02 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)