CVE-2015-3185

Priority
Description
The ap_some_auth_required function in server/request.c in the Apache HTTP
Server 2.4.x before 2.4.14 does not consider that a Require directive may
be associated with an authorization setting rather than an authentication
setting, which allows remote attackers to bypass intended access
restrictions in opportunistic circumstances by leveraging the presence of a
module that relies on the 2.2 API behavior.
Assigned-to
mdeslaur
Notes
mdeslaurintroduced by changes in 2.4, so doesn't affect 2.2
Package
Upstream:released (2.4.16)
Ubuntu 14.04 ESM (Trusty Tahr):released (2.4.7-1ubuntu4.5)
Patches:
Upstream:http://svn.apache.org/viewvc?view=revision&revision=1684524 (trunk)
Upstream:http://svn.apache.org/viewvc?view=revision&revision=1684525 (2.4)
More Information

Updated: 2020-09-10 04:42:01 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)