CVE-2015-2327 (retired)

Priority
Description
PCRE before 8.36 mishandles the /(((a\2)|(a*)\g<-1>))*/ pattern and related
patterns with certain internal recursive back references, which allows
remote attackers to cause a denial of service (segmentation fault) or
possibly have unspecified other impact via a crafted regular expression, as
demonstrated by a JavaScript RegExp object encountered by Konqueror.
Notes
 sbeattie> mongodb package uses system pcre since 2.0.0
 tyhicks> Issue affects PCRE3 only
 tyhicks> Marking 'low' since it requires PCRE to operate on untrusted regular
  expressions which is not very likely
 mdeslaur>
 mdeslaur> CVE-2015-2325_CVE-2015-2326_CVE-2015-3210_CVE-2015-5073.patch
 mdeslaur> in jessie
Package
Upstream:not-affected (uses system pcre)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected [uses system pcre])
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (uses system pcre)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system pcre)
Package
Source: pcre2 (LP Ubuntu Debian)
Upstream:not-affected
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Package
Source: pcre3 (LP Ubuntu Debian)
Upstream:released (2:8.35-8)
Ubuntu 12.04 ESM (Precise Pangolin):released (8.12-4ubuntu0.2)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:8.31-2ubuntu2.1)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2:8.38-3)
Patches:
Upstream:http://vcs.pcre.org/pcre?view=revision&revision=1495
More Information

Updated: 2019-03-26 12:14:49 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)