CVE-2015-2311

Priority
Description
Integer underflow in Sandstorm Cap'n Proto before 0.4.1.1 and 0.5.x before
0.5.1.1 might allow remote peers to cause a denial of service or possibly
obtain sensitive information from memory or execute arbitrary code via a
crafted message.
Ubuntu-Description
Kenton Varda discovered that the Cap'n Proto utility has a buffer overflow
vulnerability. An attacker could use this vulnerability to cause a crash or
possibly execute arbitrary code.
Notes
tyhicksFixed in 0.4.1.1, 0.5.1.1, and 0.6
Package
Upstream:released (0.5.1.1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [0.4.0-1ubuntu2.1])
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (0.5.3-2ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
More Information

Updated: 2020-09-10 04:40:10 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)