CVE-2015-2156

Priority
Description
Netty before 3.9.8.Final, 3.10.x before 3.10.3.Final, 4.0.x before
4.0.28.Final, and 4.1.x before 4.1.0.Beta5 and Play Framework 2.x before
2.3.9 might allow remote attackers to bypass the httpOnly flag on cookies
and obtain sensitive information by leveraging improper validation of
cookie name and value characters.
Package
Source: netty (LP Ubuntu Debian)
Upstream:released (3.9.9.Final-1, 1:4.0.31-1, 1:4.1.7-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1:4.0.34-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:4.0.34-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1:4.0.34-1)
Ubuntu 19.04 (Disco Dingo):not-affected (1:4.0.34-1)
Package
Upstream:released (3.9.9.Final-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.9.9.Final-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (3.9.9.Final-1)
Ubuntu 19.04 (Disco Dingo):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-01-14 21:16:49 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)