CVE-2015-2059 (retired)

Priority
Description
The stringprep_utf8_to_ucs4 function in libin before 1.31, as used in
jabberd2, allows context-dependent attackers to read system memory and
possibly have other unspecified impact via invalid UTF-8 characters in a
string, which triggers an out-of-bounds read.
Notes
 sbeattie> libidn2-0 does not appear to implement stringprep.
 mdeslaur> This CVE was fixed in 1.31 and regression fixed in 1.32
Assigned-to
mdeslaur
Package
Upstream:released (1.32)
Ubuntu 12.04 ESM (Precise Pangolin):released (1.23-2ubuntu0.1)
Ubuntu 14.04 LTS (Trusty Tahr):released (1.28-1ubuntu2.1)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.32-3ubuntu1)
Patches:
Upstream:http://git.savannah.gnu.org/cgit/libidn.git/commit/?id=2e97c2796581c27213962c77f5a8571a598f9a2e
Upstream:http://git.savannah.gnu.org/cgit/libidn.git/commit/?id=58c721ac2dc96bccd737f3f544f3a22a50477bbf
More Information

Updated: 2019-03-26 12:14:46 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)