CVE-2015-1859

Priority
Description
Multiple buffer overflows in plugins/imageformats/ico/qicohandler.cpp in
the QtBase module in Qt before 4.8.7 and 5.x before 5.4.2 allow remote
attackers to cause a denial of service (segmentation fault and crash) and
possibly execute arbitrary code via a crafted ICO image.
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):released (4:4.8.5+git192-g085f851+dfsg-2ubuntu4.1)
Patches:
Upstream:https://codereview.qt-project.org/#/c/108312/
Upstream:https://qt.gitorious.org/qt/qtbase/commit/51ec7ebfe5f45d1c0a03d992e97053cac66e25fe
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):released (5.2.1+dfsg-1ubuntu14.3)
More Information

Updated: 2019-03-19 12:18:03 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)