CVE-2015-1790

Priority
Description
The PKCS7_dataDecodefunction in crypto/pkcs7/pk7_doit.c in OpenSSL before
0.9.8zg, 1.0.0 before 1.0.0s, 1.0.1 before 1.0.1n, and 1.0.2 before 1.0.2b
allows remote attackers to cause a denial of service (NULL pointer
dereference and application crash) via a PKCS#7 blob that uses ASN.1
encoding and lacks inner EncryptedContent data.
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (1.0.1-4ubuntu5.31)
Ubuntu 14.04 LTS (Trusty Tahr):released (1.0.1f-1ubuntu2.15)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.0.2c-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.0.2c-1ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1.0.2c-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):released (1.0.2c-1ubuntu1)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-03-19 11:16:53 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)