CVE-2015-1379

Priority
Description
The signal handler implementations in socat before 1.7.3.0 and 2.0.0-b8
allow remote attackers to cause a denial of service (process freeze or
crash).
Ubuntu-Description
It was discovered that socat incorrectly handled signals. A remote attacker
could possibly use this issue to cause a denial of service.
Notes
Package
Source: socat (LP Ubuntu Debian)
Upstream:released (1.7.3.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.7.3.1-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.7.3.2-2ubuntu2)
Ubuntu 19.10 (Eoan Ermine):not-affected (1.7.3.2-2ubuntu2)
Ubuntu 20.04 (Focal Fossa):not-affected (1.7.3.2-2ubuntu2)
More Information

Updated: 2020-04-24 03:17:50 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)