CVE-2015-0852

Priority
Description
Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and
earlier allow remote attackers to cause a denial of service (heap memory
corruption) via vectors related to the height and width of a window.
Ubuntu-Description
It was discovered that FreeImage incorrectly handled certain PCX files. An
attacker could possibly use this issue to cause a denial of service.
Notes
Package
Upstream:released (3.15.4-4.2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (3.15.4-4.2)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.15.4-4.2)
Ubuntu 19.10 (Eoan Ermine):not-affected (3.15.4-4.2)
Ubuntu 20.04 (Focal Fossa):not-affected (3.15.4-4.2)
More Information

Updated: 2020-04-24 03:17:44 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)