CVE-2015-0292 (retired)

Priority
Description
Integer underflow in the EVP_DecodeUpdate function in crypto/evp/encode.c
in the base64-decoding implementation in OpenSSL before 0.9.8za, 1.0.0
before 1.0.0m, and 1.0.1 before 1.0.1h allows remote attackers to cause a
denial of service (memory corruption) or possibly have unspecified other
impact via crafted base64 data that triggers a buffer overflow.
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (1.0.1-4ubuntu5.25)
Trusty/esm:released (1.0.1f-1ubuntu2.11)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.0.1f-1ubuntu11)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.0.1f-1ubuntu11)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1.0.1f-1ubuntu11)
Ubuntu 19.04 (Disco Dingo):released (1.0.1f-1ubuntu11)
Ubuntu 19.10 (Eoan):released (1.0.1f-1ubuntu11)
Patches:
Upstream:https://git.openssl.org/?p=openssl.git;a=commit;h=d0666f289ac013094bbbf547bfbcd616199b7d2d (1.0.1)
Upstream:https://git.openssl.org/?p=openssl.git;a=commit;h=9febee02720902c195fe929ecfe06362c551422c (0.9.8)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-04-26 14:34:11 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)