CVE-2015-0289

Priority
Description
The PKCS#7 implementation in OpenSSL before 0.9.8zf, 1.0.0 before 1.0.0r,
1.0.1 before 1.0.1m, and 1.0.2 before 1.0.2a does not properly handle a
lack of outer ContentInfo, which allows attackers to cause a denial of
service (NULL pointer dereference and application crash) by leveraging an
application that processes arbitrary PKCS#7 data and providing malformed
data with ASN.1 encoding, related to crypto/pkcs7/pk7_doit.c and
crypto/pkcs7/pk7_lib.c.
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (1.0.1-4ubuntu5.25)
Ubuntu 14.04 LTS (Trusty Tahr):released (1.0.1f-1ubuntu2.11)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.0.1f-1ubuntu11)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.0.1f-1ubuntu11)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1.0.1f-1ubuntu11)
Ubuntu 19.04 (Disco Dingo):released (1.0.1f-1ubuntu11)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-01-14 21:16:32 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)