CVE-2015-0287

Priority
Description
The ASN1_item_ex_d2i function in crypto/asn1/tasn_dec.c in OpenSSL before
0.9.8zf, 1.0.0 before 1.0.0r, 1.0.1 before 1.0.1m, and 1.0.2 before 1.0.2a
does not reinitialize CHOICE and ADB data structures, which might allow
attackers to cause a denial of service (invalid write operation and memory
corruption) by leveraging an application that relies on ASN.1 structure
reuse.
Assigned-to
mdeslaur
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):released (1.0.1-4ubuntu5.25)
Ubuntu 14.04 ESM (Trusty Tahr):released (1.0.1f-1ubuntu2.11)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.0.1f-1ubuntu11)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.0.1f-1ubuntu11)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
More Information

Updated: 2020-07-28 19:53:25 UTC (commit d26b6ca9f5b3adb89bb036ce73ae7dab894935ec)