CVE-2015-0282

Priority
Description
GnuTLS before 3.1.0 does not verify that the RSA PKCS #1 signature
algorithm matches the signature algorithm in the certificate, which allows
remote attackers to conduct downgrade attacks via unspecified vectors.
Assigned-to
mdeslaur
Notes
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):released (2.12.14-5ubuntu3.9)
Ubuntu 14.04 ESM (Trusty Tahr):released (2.12.23-12ubuntu2.2)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
Upstream:https://gitlab.com/gnutls/gnutls/commit/d326f81daed5a1a06476d66a81584f8c7b71141d
Vendor:https://bugzilla.redhat.com/attachment.cgi?id=997548
Package
Upstream:released (3.1.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
More Information

Updated: 2020-09-10 04:34:08 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)