CVE-2015-0226

Priority
Description
Apache WSS4J before 1.6.17 and 2.0.x before 2.0.2 improperly leaks
information about decryption failures when decrypting an encrypted key or
message data, which makes it easier for remote attackers to recover the
plaintext form of a symmetric key via a series of crafted messages. NOTE:
this vulnerability exists because of an incomplete fix for CVE-2011-2487.
Notes
 mdeslaur> code isn't present in 1.5.x
Package
Source: wss4j (LP Ubuntu Debian)
Upstream:released (1.6.15-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected [1.5.8+svntag-1ubuntu1])
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.6.15-2)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.6.15-2)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.6.15-2)
Ubuntu 19.04 (Disco Dingo):not-affected (1.6.15-2)
More Information

Updated: 2019-01-14 21:16:29 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)