CVE-2015-0211 (retired)

Priority
Description
mod/lti/ajax.php in Moodle through 2.5.9, 2.6.x before 2.6.7, 2.7.x before
2.7.4, and 2.8.x before 2.8.2 does not consider the
moodle/course:manageactivities and mod/lti:addinstance capabilities before
proceeding with registered-tool list searches, which allows remote
authenticated users to obtain sensitive information via requests to the LTI
Ajax service.
Package
Upstream:released (2.8.2, 2.7.4, 2.6.7)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (3.0.3+dfsg-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.0.3+dfsg-0ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (3.0.3+dfsg-0ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (3.0.3+dfsg-0ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (3.0.3+dfsg-0ubuntu1)
More Information

Updated: 2019-04-26 14:34:09 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)