CVE-2014-9732

Priority
Description
The cabd_extract function in cabd.c in libmspack before 0.5 does not
properly maintain decompression callbacks in certain cases where an invalid
file follows a valid file, which allows remote attackers to cause a denial
of service (NULL pointer dereference and application crash) via a crafted
CAB archive.
Package
Upstream:released (0.5-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
More Information

Updated: 2019-03-19 11:16:36 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)