CVE-2014-9621

Priority
Description
The ELF parser in file 5.16 through 5.21 allows remote attackers to cause a
denial of service via a long string.
Notes
 mdeslaur> readelf.c not used in php5
 mdeslaur> introduced by fix for CVE-2014-9620
Package
Source: file (LP Ubuntu Debian)
Upstream:released (1:5.21+15-1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):released (1:5.14-2ubuntu3.4)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1:5.22+15-2ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:5.22+15-2ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1:5.22+15-2ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (1:5.22+15-2ubuntu1)
Patches:
Upstream:https://github.com/file/file/commit/65437cee25199dbd385fb35901bc0011e164276c
Package
Source: php5 (LP Ubuntu Debian)
Upstream:not-affected
Ubuntu 12.04 ESM (Precise Pangolin):not-affected
Ubuntu 14.04 LTS (Trusty Tahr):not-affected
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-01-14 21:16:22 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)