CVE-2014-9597 (retired)

Priority
Description
The picture_pool_Delete function in misc/picture_pool.c in VideoLAN VLC
media player 2.1.5 allows remote attackers to execute arbitrary code or
cause a denial of service (DEP violation and application crash) via a
crafted FLV file.
Notes
 sarnold> vlc claims the bug is in libav, but "the 2.2.0-rc2 binaries already
 fix the problem"
 mdeslaur> as of 2015-05-08, no indication of a libav fix
 mdeslaur> can reproduce with vlc 2.1.6 in trusty
 mdeslaur> can't reproduce with vlc in precise
Package
Source: vlc (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):released (2.1.6-0ubuntu14.04.2)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.2.0-0ubuntu1)
Patches:
Upstream:https://github.com/videolan/vlc/commit/4d9f343c5341399b082b84af8010f28a36c2757e
More Information

Updated: 2019-03-26 12:13:53 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)