CVE-2014-9277 (retired)

Priority
Description
The wfMangleFlashPolicy function in OutputHandler.php in MediaWiki before
1.19.22, 1.20.x through 1.22.x before 1.22.14, and 1.23.x before 1.23.7
allows remote attackers to conduct PHP object injection attacks via a
crafted string containing <cross-domain-policy> in a PHP format request,
which causes the string length to change when converting the request to
<NOT-cross-domain-policy>.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.23.7)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.23.7)
Ubuntu 19.04 (Disco Dingo):not-affected (1.23.7)
Ubuntu 19.10 (Eoan):not-affected (1.23.7)
More Information

Updated: 2019-04-26 14:34:05 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)