CVE-2014-8625

Priority
Description
Multiple format string vulnerabilities in the parse_error_msg function in
parsehelp.c in dpkg before 1.17.22 allow remote attackers to cause a denial
of service (crash) and possibly execute arbitrary code via format string
specifiers in the (1) package or (2) architecture name.
Package
Source: dpkg (LP Ubuntu Debian)
Upstream:released (1.17.22)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.17.24ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.17.24ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.17.24ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (1.17.24ubuntu1)
More Information

Updated: 2019-01-14 21:16:12 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)