CVE-2014-8124

Priority
Description
OpenStack Dashboard (Horizon) before 2014.1.3 and 2014.2.x before 2014.2.1
does not properly handle session records when using a db or memcached
session engine, which allows remote attackers to cause a denial of service
via a large number of requests to the login page.
Assigned-to
sarnold
Notes
mdeslaurthe fix for CVE-2014-8124 introduced a regression, which is
fixed here:
https://review.openstack.org/#/c/142737/
sarnoldThe python-django-openstack-auth regression fix is currently only
included in the wily package (2015-5-14) -- however, no one has complained
and testing hasn't demonstrated any problems.
horizon in precise does not appear to take the operations that auto-
instantiated django sessions in the newer releases; it looks safe.
Package
Upstream:released (2014.1.3-6)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [1:2014.1.4-0ubuntu2])
Patches:
Upstream:https://review.openstack.org/140353 (kilo)
Upstream:https://review.openstack.org/140358 (juno)
Upstream:https://review.openstack.org/140356 (icehouse)
Package
Upstream:released (1.1.6-5)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [see notes])
Patches:
Upstream:https://review.openstack.org/140352
More Information

Updated: 2020-09-10 03:12:32 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)